Lein-droid update: AAR support, multi-dexing, simpler setup

New version of lein-droid, 0.4.0-alpha6 is published. This alpha contains plenty of work that was done to fix the long standing issues with the build process.

Note that :project-dependencies feature will be removed in 0.4.0, so if you include this any dependencies in this way, please replace it with AAR dependencies. For most libraries it will be enough just to add a :dependencies vector, for your own, or other unpublished libraries, try building AAR packages for them, publish locally with lein droid local-repo and then include into :dependencies.

As always, if you experience bugs or have any questions, feel free to ask on any of the following places: